0

I'm not sure if this question fits this site, since the title specifically mentions development of WordPress.

Anyway, i am running a Linode Debian Stretch server that I just built. Previously, I was running Debian Jessie, so I decided to upgrade.

After having made a backup of /var/www/html/sensation-experience.com, which contained backup, public_html, and other things, as well as created a backup.sql, and exported my blog's content as an XML, I rebuilt my VPS.

After completing all the initial steps to set up my LAMP stack, setting up the database and user account for MariaDB, then restoring the backup.sql, moving everything back to /var/www/html/sensation-experience.com

resetting all the ownership and permissions for files and directories, I found that only one content management system is working, which is a Podcast Generator.

Since I restored the entire SQL backup, everything in that content management system was salvaged. But, what could cause WordPress to malfunction? I checked the .htaccess file and set the limit according to an article I found via a Google search, but those didn't work.

About two years ago, I attempted to do this same thing on Ubuntu 16.04 with PHP7, but I learned that WordPress worked better with PHP5. I was still using WordPress 4 at the time. Now I have WordPress5.

So, is this a PHP problem, WordPress problem, both, neither, or something else?

Wait, I think I may have found an error in

/var/log/apache2/error.log

[Mon May 27 12:17:06.635491 2019] [:error] [pid 5749] [client 162.158.106.170:23624] PHP Fatal error:  require(): Failed opening required '/var/www/html/sensation-experience.com/public_html/blog/wp-includes/class-wp-paused-extensions-storage.php' (include_path='.:/usr/share/php') in /var/www/html/sensation-experience.com/public_html/blog/wp-settings.php on line 20
1

Okay, here's what I did. If this happens, hopefully this will work favourably for you.

  1. If this is disabled by default, enable wp-debug by changing the value from false to true.
  2. Check that you have enabled WP_DEBUG_LOG and WP_LOG_DISPLAY.
  3. Try refreshing the page and see what happens.
  4. Either using WinSCP or the terminal, go to /var/log/apache2/error.log
  5. If you see that certain PHP files are missing, download a fresh copy from here.
  6. Follow the prompts in the error log to replace each file that is missing, making sure to change ownership and permissions to www-data 0640 or 0644.
  7. If, after you have replaced everything, you find that WordPress is giving you a permission denied message, type the following: # find -type f -exec chmod 640 /var/www/html/my_site/html/blog {} \; # find -type d -exec chmod 750 /var/www/html/my_site/html/blog {} \;
  8. Continue repeating this process until your blog shows up.
  9. If WordPress tells you that a plugin is missing, you can either download a new copy or delete it and install it via the dashboard.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.