0

I have created 3 categories; Europe (as a parent category) and then I have two sub-categories Croatia and Wales.

In Dashboard > Appearance > Menu I when I only add the category Europe as a menu item, all posts tagged with this category are shown correctly.

Europe item will show posts when it is like this

However, when I then add the two sub-categories underneath it (to effectively create a drop down) the page Europe will not show any posts.

Europe menu item wont load any posts on the page when structured like this

Why is this happening and is it possible to fix via the admin panel?

  • Can you, please, edit your question to make it readable. – Max Yudin May 26 at 18:49
  • You mean posts are not being shown where? Give an example, maybe a screenshot would help. – filipecsweb May 26 at 18:52
  • @filipecsweb on the website. Do the screenshots help now? – user3755632 May 26 at 19:25
0

First, really stupid question: Do you save your new menu after making the changes? Sometimes it's the little things that mess everything up.

Aside from that, it might be a theme problem. Change to one of WordPress default themes (Twenty XYZ series) and see if the problem persists.

  • Of course I am saving it! It just doesn’t seem to load the posts for some reason. Which is very strange. – user3755632 May 27 at 11:28
  • Have you tried switching themes? – WSU May 28 at 9:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.