1

We're running WP woocommerce website, we got there problem with generating links.

Steam api is generating link in this format: steam://rungame/730/76561202255233023/+csgo_econ_action_preview%20S76561198030116216A15860401386D2594883032411162261
but wordpress is changing link into this: https://rungame/730/76561202255233023/+csgo_econ_action_preview%20S76561198030116216A15860401386D16457881814965865661
Its removing "Steam" and replacing with HTTPS. Does anyone know where is problem? We're using Cloudflare and I tried disable feature "Automatic HTTPS Rewrites".

Thank you a lot for helpful replies. :)

  • I'd guess the code that's doing this is using set_url_scheme. So I'd start by editing that function in a dev environment (wp-includes/link-template.php) to throw an error if the input url starts with 'steam://', so that you can track down the code that's triggering this. Hopefully that'll point you in the right direction. Worst case there's also a filter set_url_scheme that you could use to check the original url and put 'steam://' back, but hopefully a better way – Rup May 7 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.