11

I had to uninstall WooCommerce plugin (I deleted the tables it created as well) and now I reinstalled the plugin and I doesn't automatically recreate the WooCommerce Pages. Am I stuck having to manually create the pages myself? Is there a way to have it automatically regenerate the pages?

6

Just had the same problem.

First uninstall the plugin. Then you have to delete all rows containing "woocommerce" in the table "wp_options" on your database. Especially "skip_install_woocommerce_pages". Now install the plugin again. The notification for automatically creating pages will pop up.

17

What ended up working for me was adding "&install_woocommerce_pages=true" to the Settings page URL.

  • Especially useful for WooCommerce 2.1, because that has no WooCommerce > Pages anymore. Thanks! – Ewout Dec 13 '13 at 14:07
  • 5
    What worked for me was: Go to the "System Status" tab on Woocommerce, click on the "Tools" tab at the top of the page, then click the sixth option ("Install pages"). stackoverflow.com/a/22386746/470749 – Ryan Jul 24 '14 at 0:11
  • This is much simpler than database table manipulation. E.g. simply visit http://example.com/wp-admin/admin.php?page=wc-settings&install_woocommerce_pages=true – Brylie Christopher Oxley Nov 6 '14 at 9:31
  • 3
    On new version of WooCoomerce you can use this page to create woocommerce pages automaticly: http://example.com/wp-admin/admin.php?page=wc-setup – Nuri Akman Jan 15 '16 at 8:30
  • @NuriAkmanis totally right with nowadays WooCommerce and Wordpress versions. That URLs works like a charm. – xarlymg89 Apr 20 '18 at 14:52
6

There is an easier way to get the page-creation dialog to appear.

Simply go to WooCommerce > Pages and unset all of the select boxes for pages (including the shop base option).

Then if you de-activate and re-activate it will ask you whether or not you want to install the pages.

  • This seems to do exactly what it's supposed to. If your previous pages were deleted (but still specified in WooCommerce), then just make a dummy page. Set all the select boxes to that dummy page, THEN unset them and do the steps above, then it will work. – Anriëtte Myburgh May 25 '12 at 14:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.