0

Background:

(Site is running most recent version of WordPress on DreamHost.)

This all seems to have started when I tried to get our WordPress site over to SSL. I had a certificate but going to https://example.com would throw a bunch of errors about requesting assets over http (of course). I ended up installing the Really Simple SSL plugin to smooth this out and everything seemed fine.

I had previously installed Search & Replace to try to manually resolve the http/https hard-coded values but didn't end up going through with it. Noting it just in case even just doing the "dry run" they offer might have messed something up.

Problem:

I tried to make a change to a page and it wouldn't go through. This is only happening on specific pages, and not on posts. Funnily enough, I can see via phpmyadmin that the wp_posts field post_modified is updated, but not post_content.

Attempts to Fix:

I have cleared oodles of caches (including W3 Total Cache, my own browser, and CloudFlare). I reverted the plugins folder to what it was a few days ago (before the SSL fiddling). I uninstalled all plugins and reverted to a default theme and tried to update the page in question -- problem persisted even then.

So basically I am at a loss. I don't want to have to restore the database if there is some configuration gotcha that I am missing.

Thanks for any help, and if I can provide any more information please let me know.

  • why do you try to fix mixed content issue with really simple ssl plugin? anyways. are there any errors/warnings in browser console? – Vishwa May 3 '19 at 3:43
  • @Vishwa I used Really Simple SSL because I don't know how else to solve the issue. Conversion to SSL is not something I've dealt with before, plus this particular site is made up of 30+ different plugins and I don't know how to track down all the http requests. I've added the list of errors that comes up without Really Simple SSL activated. – bitterleaves May 3 '19 at 22:01
0

Turns out the problem (certain pages not updating) had nothing to do with the SSL conversion. The issue was the tmp directory running out of space. As the site is on DreamHost VPS I was able to clear this directory by restarting the server. Pages are now able to update again.

Additional debugging steps:

  • set WP_DEBUG and WP_DEBUG_LOG to true
  • examine debug.log which showed PHP warnings:
    • write failed: no space left on device and
    • failed to write session data (files)

Searching these errors pulled up info about issues with tmp directories.

Relevant DreamHost FAQ page: /tmp directory overview

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.