0

I mail is configured and is working on other sites in localhost but I am not able to find whats the problem with current wordpress project I am working on. I tested using WP Mail SMTP plugin also but its not working for this particular wordpress installation only. Even on the live server it has a problem and I had duplicated the same site on my local machine using duplicator plugin.

There was a problem while sending a test email. Related debugging output is shown below:

Versions: WordPress: 5.1.1 WordPress MS: No PHP: 5.6.40 WP Mail SMTP: 1.2.5

Params: Mailer: mail Constants: No

Server: PHP.mail(): Yes Apache.mod_security: No

  • 2
    Do the SMTP credentials that you configured in the plugin work from other machines? (You said you duplicated the live site locally - did that work or not?) If they do, then output SMTP might be firewalled off from the server. Your host may require you use their SMTP server or email service (e.g. Amazon SES). Can you log into the server and try an outbound SMTP connection to your service from there? – Rup Apr 26 at 13:07
  • Verify your SMTP credentials and other settings. Make sure you are using correct values for your particular SMTP account (verify with your provider) such as TLS/SSL, correct port values, etc. – butlerblog Apr 26 at 13:22
  • @Rup Even in local its not working. The plugin is working fine in other WP sites. Its not a plugin problem. – Abhilash Narayan Apr 26 at 13:38
  • Then it sounds like it's an SMTP credentials problem. Are you sure that they work? – Rup Apr 26 at 13:39
  • @Rup Yeah I am using same credentials for other site, its working but not on this site. – Abhilash Narayan Apr 26 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.