1

I'm trying to configure a WP Multisite to run locally, all is fine on the server, but getting this to run locally is turning into quite a pain. The issue I'm currently seeing is that some of the sites won't load anything except the home page when the permalink settings are anything but plain. The inconsistency is confusing me.

So far I've added the following code:

wp-config.php

define('WP_DEBUG', true);

/* Multisite */
define('WP_ALLOW_MULTISITE', true);

/* Multisite stage two */
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', '******');
define('PATH_CURRENT_SITE', '/wp/******/site/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

.htaccess

RewriteEngine On
RewriteBase /wp/******/site/
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

I've...

  • Updated all the site values in the DB
  • Reset the permalinks multiple times
  • Deactivated all plugins
  • Made sure the rewrite module is turned on

All the searches for this issue bring me to the same 3 solutions I've tried again and again. Any help will be hugely appreciated!

  • What do you have in your wp_blogs table and also each of the wp_#_options tables for siteurl and home? – Alexander Holsgrove Apr 24 at 8:25
  • In wp_#_options I have http://10.0.19.14/wp/****/site/{theme} for siteurl & home. In wp_blogs I have 10.0.19.14 for domain & /wp/****/site/{theme} for path On one of the sites live (which is under development) I've just test changed a permalink setting, thinking this would be a closed environment to that theme, I now have this same error live! The urgency has just got a lot larger :/ I appreciate you trying to help – TidyLuke Apr 24 at 8:48
  • I'm not sure if you should have the theme in the wp_#_options URLs as these normally just point to the root URL - try just http://10.0.19.14/wp/****/site/ if that is the root of your WordPress installation. – Alexander Holsgrove Apr 24 at 9:40
  • Unfortunately removing the theme name from the wp_#_options tables makes all pages of the changed sites display index.php only – TidyLuke Apr 24 at 10:00
  • Silly question, but do you have mod_rewrite enabled on your local server? – Alexander Holsgrove Apr 24 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.