This wp site is a redesign of an old non wp site. I have made the site on the same server, but in a different directory named /nou until it was ready. everything was fine until I copied the site in the root directory.

the site in the construction was on www.lawoffice.ro/nou and when it was copied to the root www.lawoffice.ro. it still continue to try to reach the homepage in the /nou directory. I have changed the site adress in the wp-config like this:

define( 'WP_HOME', 'http://www.lawoffice.ro' );
define( 'WP_SITEURL', 'http://www.lawoffice.ro' );

but nothing.

I also tried in the themes functions.php like this:

update_option( 'siteurl', 'http://www.lawoffice.ro/' );
update_option( 'home', 'http://www.lawoffice.ro/' );

But still nothing.

Then I find and replaced all the links in the database, but still noting.

Ewerithing else is fine, all the other pages are working in the right directory, only the first page try to reach the www.lawoffice.ro/nou directory.

Weirdly if I copy the link from the dashboard and and insert it in the address bar it look right: www.lawoffice.ro, but when I press enter the /nou keeps appearing in the end.

I have to resolve this problem urgently

Please help

Thank you.

  • Do you have something in your .htaccess file that needs updated? Go to Settings > Permalinks and save that page a couple times. Also try it in a new browser or private to avoid cache issues. Commented Apr 18, 2019 at 14:20
  • You have right, in a private browsing it is ok, thank you Commented Apr 18, 2019 at 14:27

1 Answer 1


When changing your site URL or even just adding an SSL its a good idea to clear your browser cache before testing. Or simply use a new browser or open a private window to avoid the issue.

To clear you browser cache you can do this, in Chrome.

Click the 3 dots to go to Settings > More tools > Clear browsing data

clear cache step 1

This will open a pop-up with options on what to delete.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.