I like Gutenberg a lot, however, the tips at the beginning of each page load drives me mad. I would like to disable the nagging tips forever and ever via code.

Please don't post "Disable Gutenberg" plugin, I've already seen that. I want to do it via a couple of lines of code in my theme.

There must be a hook, but I couldn't find it. Thanks for a hint.

enter image description here


enter image description here

Update #1:

After asking from @leymannx I checked how these settings are stored. It turned out that settings are not permanent, they are saved in the browser as localStorage.

key: WP_DATA_USER_{id}:
value: {

Update #2:

Gutenberg tips can be disabled by using dispatch('core/nux').disableTips() (NUX package) and action hook enqueue_block_editor_assets.

file functions.php:

function se334561_editor_tips() {

        // --- to use in plugin ---
        // plugins_url('/disable-tips.js', __FILE__),
        get_stylesheet_directory_uri() . '/disable-tips.js',
add_action('enqueue_block_editor_assets', 'se334561_editor_tips');

file disable-tips.js:

    var isVisible = wp.data.select('core/nux').areTipsEnabled()
    if (isVisible) {
| improve this answer | |
  • Is this globally for every user? Is there a way to configure this per code as well? So that when I ship a plugin to a client it deactivates the tips when this plugin gets activated? – leymannx Apr 17 '19 at 7:01
  • 1
    If it’s an option able checkbox in the admin area they’ll be away to toggle it for all as the values got to be stored somewhere you should in code be able to set that value for all users on init or something, try to find where it stores that value in the DB – Daniel Vickers Apr 17 '19 at 7:40
  • 1
    @leymannx This would require additional code (js + php) which, after changing areTipsEnabled, writes the state to DB and restores it when the user logs in. – nmr Apr 17 '19 at 7:50
  • 1
    That is awesome, I'll try it out tomorrow and check the answer if it works. Thank you! – user3135691 Apr 17 '19 at 21:21
  • 1
    @user3135691 In plugin file replace get_stylesheet_directory_uri() . '/disable-tips.js' with plugins_url('/disable-tips.js', __FILE__). – nmr Apr 18 '19 at 9:08

As @nmr found out this seems to be stored browser-wise only. Though I found a workaround to simply hide it via CSS. Quick and dirty.


// Add backend styles for Gutenberg.
add_action('enqueue_block_editor_assets', 'gutenberg_editor_assets');

function gutenberg_editor_assets() {
  // Load the theme styles within Gutenberg.
  wp_enqueue_style('my-gutenberg-editor-styles', get_theme_file_uri('/assets/gutenberg-editor-styles.css'), FALSE);


.components-popover.nux-dot-tip {
  display: none !important;

Source: Creating theme editor styles for Gutenberg

| improve this answer | |
  • Yes, this solution also came to my mind but as you have said: it's quick 'n dirty. Thank you for your help. – user3135691 Apr 17 '19 at 9:49

Small plugin that should fix it: https://wordpress.org/plugins/disable-welcome-messages-and-tips/

The relevant part of the code is this CSS:

  .wp-admin .components-popover.nux-dot-tip {
    display: none !important;
  .wp-admin .components-modal__screen-overlay {
    display: none !important;
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.