0

The jump made in React 16 seem substantial enough from 15 in terms of how things are done, especially with the new hooks that Fiber provided, so what version does it use and is it considered bad practice / a no-no to use React 16 when a version of React 15 is provided to me?

2

WordPress 5.1.1 uses React 16.6.3. You can see this in the package.json file in the development version of WordPress on Trac: https://core.trac.wordpress.org/browser/tags/5.1.1/package.json?rev=44861

This has already been updated in trunk to 16.8.4, so the next major version of WordPress will use at least that version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.