0

I don't get this but for all wp admin users except the original main user i get a strange error which causes the visual editor to fail:

load-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,jquery-ui-draggable,jquery-ui-button,jquery-ui-position,jquery-ui-dialog,heartbeat,autosave,suggest&load[]=,wp-ajax-response,jquery-color,wp-lists,postbox,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box,underscore,w&load[]=ord-count,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load[]=uest,media-views,media-editor,media-audiovideo,mce-view,imgareaselect,image-edit,svg-painter,wp-auth-check&ver=4.9.5:690 Uncaught TypeError: Cannot read property 'hasClass' of undefined
    at HTMLDocument.<anonymous> (load-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,jquery-ui-draggable,jquery-ui-button,jquery-ui-position,jquery-ui-dialog,heartbeat,autosave,suggest&load[]=,wp-ajax-response,jquery-color,wp-lists,postbox,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box,underscore,w&load[]=ord-count,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load[]=uest,media-views,media-editor,media-audiovideo,mce-view,imgareaselect,image-edit,svg-painter,wp-auth-check&ver=4.9.5:690)
    at HTMLDocument.dispatch (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-sortable,moxiejs,&load[]=plupload&ver=4.9.5:3)
    at HTMLDocument.r.handle (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-sortable,moxiejs,&load[]=plupload&ver=4.9.5:3)
    at Object.trigger (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-sortable,moxiejs,&load[]=plupload&ver=4.9.5:3)
    at Object.a.event.trigger (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-sortable,moxiejs,&load[]=plupload&ver=4.9.5:9)
    at HTMLDocument.<anonymous> (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-sortable,moxiejs,&load[]=plupload&ver=4.9.5:3)
    at Function.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-sortable,moxiejs,&load[]=plupload&ver=4.9.5:2)
    at a.fn.init.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-sortable,moxiejs,&load[]=plupload&ver=4.9.5:2)
    at a.fn.init.trigger (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-sortable,moxiejs,&load[]=plupload&ver=4.9.5:3)
    at Object.<anonymous> (load-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,jquery-ui-draggable,jquery-ui-button,jquery-ui-position,jquery-ui-dialog,heartbeat,autosave,suggest&load[]=,wp-ajax-response,jquery-color,wp-lists,postbox,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box,underscore,w&load[]=ord-count,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load[]=uest,media-views,media-editor,media-audiovideo,mce-view,imgareaselect,image-edit,svg-painter,wp-auth-check&ver=4.9.5:48)

I have given All users (4) the same role administrator, but only the "main" user with Amdinistrator rol has the correct visual editor.

Now with some trial and error i notice selecting the button 'Disable the visual editor when writing' for an user the visual editor seem to appear correctly. I know the qtranslate has been edited as it doesn't work with WP 4.9.x anymore. But how can i check the qtranslate files for specific conditional statements for Administrator user

My conclusion is the old plugin qtranslate causes the problem, how can i make it to work with the other users as well???

"documentBaseUrl" is set for Administrator user but not for all other users?

Is it possible to add Adminstrator role to another user so I have 2??

Any tips?

(btw: stuck to WP 4.9.5)

  • | My conclusion is the old plugin qtranslate causes the problem... - have you actually verified that? Did you try to disable it and then check for errors? – dboris Apr 10 at 14:23
  • @dboris, yes that is what i also concluded but for the "first" user the qtranslate works with tinymce..........so now i am trying to find the difference between the "first' user and any other user i add btw: tx for replying – alex Apr 10 at 14:25
  • :) I have quoted you, it was not my conclusion. I wanted to ask you if you have actually verified that it is the qtranslate plugin that causes the problem, by disabling the plugin and then checking for errors. – dboris Apr 10 at 14:27
  • ah so, no not yet. i checked 'Disable the visual editor when writing' on the user profile page and the visual editor seemed to render ok. So as the qtranslate plugin was not triggered to be loaded for the visual editor i concluded qtranslate would be the cause? Would turning the plugin on/off cause the site to crash?? – alex Apr 10 at 14:39
  • 1
    There is a possibility that the front end of website will crash (some PHP fatal errors, if plugin entities/functions are used), but it only takes like 10 seconds to test this. – dboris Apr 10 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.