0

I was installing WORDPRESS on my Ubuntu 18.04 LTS and it showed the following which i have tried but has failed to work it out, so help me guys solve it.Thanks

Sorry, but I can’t write the wp-config.php file.

You can create the wp-config.php file manually and paste the following text into it

  • 2
    Welcome to WordPress Stack Exchange! We love to help you but debugging always needs to be done by you. In your case the error message pretty clearly states what's wrong. So please update your question and tell us what you've tried so far and where exactly you are stuck. Thank you! – leymannx Apr 3 at 21:24
0

This is probably one for ServerFault, but it's basically because, as the message says, the permissions on the wp-config.php file are incorrect, or the ownership is incorrect. Your webserver is unable to edit the file to save your database details.

Do you have a server control panel, or SSH access? You need Apache or whatever user your server is using to be able to read and write to that file (initially). The file should be 644 initially, but you then want to tighten that down to 440 or 400.

Have a look at the documentation here: https://wordpress.org/support/article/changing-file-permissions/

You may need to run a chmod or chown on the file.

Alternatively, just edit the file manually and fill our your database connection details.

  • Not sure who gave me the downvote, care to explain why? – Alexander Holsgrove Apr 4 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.