-1

I can't upload files with more than 1MB, but i haven't change any configuration. I have a lot of files with more than 5MB uploaded before, but i don't know why now i can't... The error is "Failed to write file to disk."

In my media page says max file size is 100MB. Any idea how i can solve this?

I am newbie with WordPress, and never see this problem before... I read this topic here but this doesn't helped me, i installed this plugin to try improve my limit, but this changed my limit to 0B.

closed as off-topic by rudtek, Jacob Peattie, Nathan Johnson, cjbj, Rick Hellewell Apr 8 at 1:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that are too localized (such as syntax errors, code with restricted access, hacked sites, hosting or support issues) are not in scope. See how do I ask a good question?" – rudtek, Jacob Peattie, Nathan Johnson, cjbj, Rick Hellewell
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Is there any chance you've hit a limit on your hosting account, i.e. you have run out of disk space or disk quota? – Rup Apr 1 at 12:32
  • this article will surely help wpbeginner.com/wp-tutorials/… – Raashid Din Apr 1 at 12:34
  • There also might be an upload file size limit enforced by the webhost. – Loren Rosen Apr 1 at 16:08
  • Tips from your link @RaashidDin doesn't worked for me – Matheus Ribeiro Apr 1 at 16:21
  • How can i see limit from my host account? I don't know – Matheus Ribeiro Apr 1 at 16:22
1

First and most important step. Check and make sure your hosting account has the available space. Login to your hosting control panel and check how much disk space you have used.

Next verify your PHP settings are actually what you have tried to set them to (this will tell you the limits set in PHP):

Create a PHP file in your root WordPress directory:

phpinfox823842832.php

Inside that PHP file put:

<?php
phpinfo();

Then browse to http://yourdomain.com/phpinfox823842832.php

You can review the PHP settings to verify the overrides you are using are actually being used. After doing this, remove that file.

Review this site for more details on checking and setting upload limits in WordPress: https://kinsta.com/blog/wordpress-maximum-upload-file-size/#

Next check your folder permissions, using FTP or your web hosting control panel, make sure that directories are set to 755: https://www.hostpapa.com/knowledgebase/fix-upload-failed-write-file-disk-error-wordpress/

Have you tried uploading files via FTP to verify that you can actually upload to your hosting account?

Not the answer you're looking for? Browse other questions tagged or ask your own question.