0

Custom Fields not showing on edit page. When I look at Screen Options it doesn't even show up. Picture of screen options

I've looked around for a while and saw that people who had the Advanced Custom Fields ran into the same issue. However, I do not have that plugin installed and I haven't found any other help online.

Solution: The Karma theme removes the custom fields meta box in the file Karma/framework/site-options-functions.php. If you go to Appearance -> Site Options you'll be able to show the hidden meta boxes.

  • What post type are you on? – NightHawk Mar 28 at 21:26
  • @NightHawk it's a page – Eli Mar 28 at 22:09
  • Maybe one your plugins or your theme has a function (remove_meta_box) that disables / removes the custom fields metabox? – Antti Koskinen Mar 29 at 11:54
  • @Eli I can confirm that it should natively be there for pages, so it could be the theme or a plugin that's removing that. You could disable each plugin one at a time to see if it comes back. – NightHawk Mar 29 at 13:52
  • Figured it out, it's the Karma theme – Eli Mar 29 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.