0

flowchart

Hello, please see the flowchart. Basically, I had a problem and contacted my hosting support. The person in charge then told me that there were some core Wordpress files that had to be replaced etc. But after some going back and forth, I realized that she was working on the wrong Wordpress multisite network.

After that, I realized that I can't login to the dashboard of subsites in my Multisite Installation TWO. When I typed in domain.com/temp/subsite1/wp-admin, I get a page like this: (https://www.awesomescreenshot.com/image/3932433/15cd8d845f7cb7feda608ca4524f11a5) and the links in the page all link to pages in Multisite Installation ONE.

How do I set the subsites back to Multisite Installation TWO?

Thank you

Chronology of Events:

Initial problem:

Fatal error: Uncaught Error: Call to a member function add_rewrite_tag() on null in /home/senscoms/public_html/temp/wp-includes/rewrite.php:173 Stack trace: #0 /home/senscoms/public_html/temp/wp-includes/class-wp-taxonomy.php(405): add_rewrite_tag('%page_category%', '([^/]+)', 'page_category=') #1 /home/senscoms/public_html/temp/wp-includes/taxonomy.php(427): WP_Taxonomy->add_rewrite_rules() #2 /home/senscoms/public_html/temp/wp-content/aam/extension/plus-package/PlusPackage.php(84): register_taxonomy('page_category', 'page', Array) #3 /home/senscoms/public_html/temp/wp-content/aam/extension/plus-package/PlusPackage.php(50): AAM_PlusPackage->registerPageCategory() #4 /home/senscoms/public_html/temp/wp-content/aam/extension/plus-package/PlusPackage.php(326): AAM_PlusPackage->__construct() #5 /home/senscoms/public_html/temp/wp-content/aam/extension/plus-package/bootstrap.php(42): AAM_PlusPackage::bootstrap() #6 /home/senscoms/public_html/temp/wp-content/plugins/advanced-access-manager/Application/Extension/Repository.php(16 in /home/senscoms/public_html/temp/wp-includes/rewrite.php on line 173

Fatal error: Uncaught RuntimeException: Unable to parse the language from the translations file in /home/senscoms/public_html/temp/wp-content/plugins/wpml-string-translation/classes/translations-file-scan/translations-file/wpml-st-translations-file-locale.php:46 Stack trace: #0 /home/senscoms/public_html/temp/wp-content/plugins/wpml-string-translation/classes/translations-file-scan/wpml-st-translations-file-entry.php(165): WPML_ST_Translations_File_Locale->get() #1 /home/senscoms/public_html/temp/wp-content/plugins/wpml-string-translation/classes/jed-translations/wpml-st-jed-file-update-hooks.php(47): WPML_ST_Translations_File_Entry->get_file_locale() #2 /home/senscoms/public_html/temp/wp-includes/class-wp-hook.php(286): WPML_ST_JED_File_Update_Hooks->update_imported_file(Object(WPML_ST_Translations_File_Entry)) #3 /home/senscoms/public_html/temp/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /home/senscoms/public_html/temp/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #5 /home/sensco in /home/senscoms/public_html/temp/wp-content/plugins/wpml-string-translation/classes/translations-file-scan/translations-file/wpml-st-translations-file-locale.php on line 46

What the host replied:

some core Wordpress files were messed, so once I updated those with a fresh one and had to change the theme to twentyseventeen your website came back to regular: http://www.sens.com/wp-login.php

You may need to flush your DNS and empty your browser's cache and cookies. Here are two kb articles that outline these processes

>> But that's the wrong one, it's Multisite Installation One's network so my initial problem still wasn't solved and my debug report for Multisite Installation Two showed this:

Fatal error: Uncaught Error: Call to undefined method WP_Error::has_errors() in /home/senscoms/public_html/temp/wp-login.php:58 Stack trace: #0 /home/senscoms/public_html/temp/wp-login.php(1045): login_header('Log In', '', Object(WP_Error)) #1 /home/senscoms/public_html/temp/wp-content/plugins/wps-hide-login/classes/plugin.php(525): require_once('/home/senscoms/...') #2 /home/senscoms/public_html/temp/wp-includes/class-wp-hook.php(286): WPS\WPS_Hide_Login\Plugin->wp_loaded('') #3 /home/senscoms/public_html/temp/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /home/senscoms/public_html/temp/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #5 /home/senscoms/public_html/temp/wp-settings.php(471): do_action('wp_loaded') #6 /home/senscoms/public_html/temp/wp-config.php(104): require_once('/home/senscoms/...') #7 /home/senscoms/public_html/temp/wp-load.php(37): require_once('/home/senscoms/...') #8 /home/senscoms/public_html/temp/wp-blog-header.php(13): require_once('/home/senscoms/...') #9 /hom in /home/senscoms/public_html/temp/wp-login.php on line 58

Fatal error: Uncaught Error: Class 'WP_Block_Type_Registry' not found in /home/senscoms/public_html/temp/wp-includes/script-loader.php:2421 Stack trace: #0 /home/senscoms/public_html/temp/wp-includes/class-wp-hook.php(286): wp_enqueue_registered_block_scripts_and_styles('') #1 /home/senscoms/public_html/temp/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #2 /home/senscoms/public_html/temp/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #3 /home/senscoms/public_html/temp/wp-includes/script-loader.php(2405): do_action('enqueue_block_a...') #4 /home/senscoms/public_html/temp/wp-includes/class-wp-hook.php(286): wp_common_block_scripts_and_styles('') #5 /home/senscoms/public_html/temp/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #6 /home/senscoms/public_html/temp/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #7 /home/senscoms/public_html/temp/wp-includes/script-loader.php(2231): do_action('wp_enqueue_scri...') #8 /home/senscoms/public_html/temp/wp-includes/class in /home/senscoms/public_html/temp/wp-includes/script-loader.php on line 2421

What the host replied:

I have reloaded wp-includes and wp-admin folders and also replaced the wp-settings.php file with the same file from the fresh Wordpress installation. The problem was related to some conflict inside the settings file and Wordpress core files. All previous versions have been removed to 'filename-BAK'. Now your site and wp-admin work fine.

>> But when I checked again, I realized she was working on Multisite Installation ONE again despite having told her she's working on the wrong site. After that, more problems happened at Multisite Installation TWO:

Issue #1a: My users can no longer logged in. From my network admin dashboard panel, the users are still in existence. Yet, despite keying in the correct password and username, the system is unable to log the user in.

Issue #1b: When the user clicks on "Lost your password" link and keys in the registered email address, the system says that "there is no registered user with that email address"

Issue #2: When I try to access my WP admin now, it seems that I will automatically be redirected to the main site.

i.e My main site is www.domain.com but as mentioned earlier, I'm working on building a whole new site on www.domain.com/temp and the plan is, when www.domain.com/temp is completed, I will make a copy and migrate it to www.domain.com while keeping a copy at www.domain.com/temp for future testing purposes.

And I previously had a plugin activated that masks my wp admin page link so my login address is actually: domain.com/temp/loginnow instead of domain.com/temp/wp-admin

However, now, when I key in domain.com/temp/loginnow, I get the default Wordpress page instead of the login page. And when I key in domain.com/temp/wp-admin, I get redirected to this link: http://www.domain.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.domain.com%2Fwp-admin%2F&reauth=1 and as mentioned earlier, I can't login because the system says that the registered user doesn't exist.

So it seems like the Main site is merged with the development site

Yet, when I try to register a new account, I can't do so either.

But when I login by keying in www.domain.com/wp-admin (not the temp site) directly, I can login. But, after logging in, I can't access my www.domain.com/temp WP admin dashboard.

What the host replied:

Since the previous fix was not what you needed, I have renamed the 'clean' default wp-settings.php to 'wp-settings.php-CLEAN' and brought your previous custom wp-settings.php file back, so your developer could work on it and test it in the real time.

Then I was on the phone with the host CSO and while he was working on it over at his side, he told me to replace wp-admin and wp-includes folder with freshly downloaded ones via FTP. So I'm not sure of other changes that he may have made but I can now login to WP Admin using domain.com/temp/wp-admin

However, I'm facing this subsites-seem-to-be-in-wrong-multisite-network problem now.

  • Have your host undue the changes or restore a backup if they have too. – RiddleMeThis Mar 22 at 19:07
  • noooooo... they are taking a long time to fix it. I was on the phone with them earlier and restoring a backup is out of the question because I've made quite a few changes over the last few days on the main site and didn't notice that the subsites are all screwed until I tried to access one of the subsite's dashboard just now. – celebrian Mar 22 at 19:17
  • without knowing what changed its hard to say what needs fixed? If they files just got transferred to the wrong place then you can simple just FTP them into the correct place. If setting have been adjusted (database stuff) then it will be much more complicated. – RiddleMeThis Mar 22 at 19:22
  • oh i see... sighs, I can only wait helplessly for my host to save me then >.< – celebrian Mar 22 at 19:53
  • Instead of ranting you could provide more details about what you requested from your host and what was changed, that would be helpful to someone trying to help – RiddleMeThis Mar 22 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.