0

I am trying to include the SSL certificate generated by my host on my Wordpress site. According to the instructions from the web host, all that is left to do, is changing the WordPress Address and Site Address to begin with https.

After clicking on Save Changes, it's trying to use the https prefix in order to save the changes. However, the settings are not updated yet, so my browser gives the following error:

SSL_ERROR_INTERNAL_ERROR_ALERT 

Now my login to Wordpress is expired and I can not access the wp-admin login page anymore, as the same error is given by the browser. The homepage works fine on http, but when trying to access the control panel, the browser tries to fetch the https URL, which is not working.

The hosting tried to ask me 20€ to investigate this further.

Site URL: http://thefoursaisons.com/

Thank you for the help in advance!

0

This indicates that the SSL certificate was not installed correctly, or that the server is not configured to accept SSL connections.

It is not an error with the certificate per se, but rather with the server setup / installation of that certificate. The web browser is failing to even connect to the server over HTTPS, much less read and verify the certificate.

I would suggest you reinstall the SSL certificate, paying close attention to how it is configured. Also read up on your hosts documentation if there is anything you need to do to enable SSL connections for the server. There may be a setting you can do yourself, or it may be something they need to do on their end.

In the meantime, to get access to your wp-admin again, if you have access to your database, go into your WordPress table called wp_options. Change site_url and home_url back to http. They will likely be the first two rows in that table.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.