0

I have a wordpress website however I am not able to make the pretty permalinks work on it. The htaccess fil is writable on the server with file permissions 777.

So kidly guide me on the issues and how can I fix it. Here's the code for .htaccess file

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress
4
  • can you please put your code here of .htaccess.
    – user147874
    Mar 20, 2019 at 6:06
  • Is it Apache? Is mod_rewrite installed and enabled? Wordpress is in the root directory or subdirectory?
    – nmr
    Mar 20, 2019 at 7:20
  • Check similar questions e.g. this.
    – nmr
    Mar 20, 2019 at 7:26
  • this is not code issues but its server issues please check it is your server is not shared server it is dedicated server so you need to config your self okay.
    – user147874
    Mar 20, 2019 at 10:46

1 Answer 1

0

If you have dedicated server then you must follow the below steps to run with .htacess

first of note that you need to create a configuration file for each site on your server using FTP.

as below

/etc/apache2/sites-available

go above path and then create file with below formate

e.g.

domain_name.domain_extension.conf

{ hello.com.conf }

add below code into it

<VirtualHost *:80>
    ServerAdmin [email protected]
    ServerName hello.com
    ServerAlias www.hello.com
    DocumentRoot /var/www/html  # your site data path
    <Directory "/var/www/html"> # your site data path
       Options FollowSymLinks
       AllowOverride All  
       Order allow,deny
       Allow from all
    </Directory> 
    ErrorLog /dev/null
    CustomLog ${APACHE_LOG_DIR}/access.log combined  # to check your log 
</VirtualHost>

after setup it.

please switch your permalink two-time vice versa and update your link in WordPress database.

and check I hope its working.

If not working, please restart apache server then.

3
  • OK let me check it once as it is dedicated server Mar 20, 2019 at 10:34
  • Yes, check to update me. and other this is your .htaccess is not working now. you can check using redirect URL code e.g 301 code
    – user147874
    Mar 20, 2019 at 10:39
  • The important part here is the AllowOverride All (and Options FollowSymLinks) directives in the appropriate <Directory> container. (You should avoid using line-end comments as Apache does not support them.)
    – MrWhite
    Mar 20, 2019 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.