0

You know there´s a direct access to every wordpress site right on the left side of the admin bar (or tool bar) once you get access to the wp dashboard which is intended to connect your website backend to the frontend.

Well, this direct access (aka "My Site") is missing from the admin bar of my website. I have privileges as super-admin, I´ve been trying to find an answer for several days and the usual problem about "admin bar" is people asking how to disable it or that it just dissapeared.

My problem is completely different. I don´t want to disable the admin bar and it´s not missing either. What it´s actually missing is "My Site" direct access and I don´t know how to recover it.

I´ve already tried by checking on functions.php admin-bar.php and class.admin.bar.php but (since I´m not a code expert) it´s been really difficult to me.

This is a caption from my website admin dashboard so you can take a look at the problem I´m talking about.

enter image description here

If anyone could help me solving this problem I´d really appreciate it.

Thanks in advance.

  • One of the first things I usually recommend is disabling all plugins to see if that solves the problem. Have you tried that already? – MikeNGarrett Mar 19 at 1:38
  • I´m afraid I can´t do what you suggest. There´s the risk of loosing valuable info if I do so. Though I really appreciate your concern. – Lowry_1982 Mar 19 at 2:23
0

Finally, I managed to solve the problem. And I have to recognize I was somehow arrogant by easily dismissing @MikeNGarret response.

However, he was completely right and I truly apologize.

One of the plugins I was using was causing the problem, so I want to tell those who might have the same problem that the plugin itself is called "Cherry White Label".

By deactivating it I was able to recover the direct access to my site´s frontend from the admin panel.

As I said when commenting to @MikeNGarret, I was really afraid of losing valuable info just by deactivating all of my plugins. However, I did it one by one and I finally figured out which one was causing all this mess.

Once again, thanks to @MikeNGarret for pointing me in the right direction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.