0

I activated the Multisite feature. I'd like to create a site in a subdomain.

I have two questions:

  • do I have to create a subdomain on the server before creating a site within the multisite admin dashboard, or after?
  • if yes, do I have to install a WordPress installation in this subdomain before creating a site within the multisite admin dashboard, or after?

I found this on StackExchange but it does not help me or I just don't understand.

Subdomain multisite gives 404 on sub sites

Thanks,

François

0

Welcome into the community.

To answer to your question:

do I have to create a subdomain on the server before creating a site within the multisite admin dashboard, or after?

yes, you need to create subdomains on your server using cPanel or plesk.

if yes, do I have to install a WordPress installation in this subdomain before creating a site within the multisite admin dashboard, or after?

You don't need to install wordpress for the subdomains. Be careful to point the root of every created subdomain to the root of your wordpress multisite installation. Multisite network will share the same wordpress installation, so you don't need to reinstall it each time you add a subdomain.

I had a similar issue, you can read the topic here.

  • Thanks. I now have a fully functional multisite. I made the mistake of not pointing my subdomain to the root of the main domain. And for those using SSL (https), don’t forget to change the setting of your new site from http to https. In my case, WordPress automatically add http instead of https so that my site didn’t display at all: Go to the network dashboard, then to Sites, click Modify when hovering on a site name, click on the Settings tab, then change the first two fields, Siteurl and Home, by adding an s to http. – Francois Maurice Mar 18 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.