0

Recently it has become impossible to change the author of any posts on my blog. I am administrator off the blog. Other admins have the same problem.

It doesn't seem code related; I've checked out older versions in git off which I'm sure it worked, but the option is still gone.

I've already checked my user capabilities, I have the "edit_others_posts" capability.

I have disabled all plugins, but that didn't help.

Is there some setting that is stored as a user setting that might by accident have been changed?

2 Answers 2

1

Are you sure you have enabled Author from Screen Options in Post area?

You can check the screenshot attached below for more info.

Enabling Author from Screen options WordPress

0

The dropdown only shows when there are multiple users with author rights available.

I had only my own admin account and several subscribers locally, in which case apparently the dropdown doesn't render at all. In production, there is a different bug that has the side effect that the author dropdown also doesn't render.

1
  • Jasper. This isn't actually an answer. You should add this as commentary to your question or as a comment to the provided answer.
    – rudtek
    Mar 11, 2019 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.