Hey sorry for the newb question but I have been looking around and could not find my answer.

I have a multisite network and polylang for translation

site 1 primarydomain.com will be in 3 language but with /en /sp /pt

site 2 sub.primarydomain.com will be 3 language but by domain en should show user drdomain.com es should show user doctordomain.com pt should show user doutordomain.com

right now the basic primary and subdomain work well, but how can i make all the changes for site 2 to work as said above

Any help would be appreciated


ok i made the domain change so now i have firstdomain.com and seconddomain.com but, in polylang i choose set languague by domain, english=seconddomain.com, portuguese=thirddomain.com and spanish=fourthdomain.com,

the english one work well, but the portuguese and spanish ones redirect to firstdomain.com :/

1 Answer 1


Go into the network admin screen. Then edit the 2nd site. Change the URL (in several places) to the www.seconddomain.com name.

Since that screen is essentially the wp-options table, there may be other places where you have to change the URL. Plus the need to change the URLs for all media files.

To do that most easily, use a search/replace plugin (I like Better Search and Replace) on that 2nd domain (via it's Dashboard) to replace the old URL with the new URL. Be careful about what tables you specify - they should only be the tables for the second site.

And, of course, a good backup of the multi-site before you do all this is always a good idea.

  • I just edited the url of second site in admin, but now i cant go to 2nd site dashboard it redirects me to firstdomain.com/wp-signup.php?new=drlandivar Mar 2, 2019 at 12:33
  • You need to do the edit from the Network Admin screen, not the sub-sites' screen. And, of course, the nameservers for your 2nd domain need to point to the server IP address. Also, check your htaccess file for the main site; should be as recommended in the Codex. Mar 2, 2019 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.