1
Uncaught ReferenceError: columns is not defined  load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:83

at Object.initToggles (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:83)
at Object.init (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:83)
at HTMLDocument.<anonymous> (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:83)
at i (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:2)
at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:2)
at Function.ready (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:2)
at HTMLDocument.K (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:2)
initToggles @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:83

    init @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:83
(anonymous) @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:83
i @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:2
fireWith @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:2
ready @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:2
K @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-u&load[]=i-droppable,wp-ajax-response,jquery-color,wp-lists,postbox,nav-menu&ver=4.9.9:2

please help me on this, it is happening in production

5
  • Looks like the variable columns in /wp-admin/js/nav-menu.js is not initialised, although it should be a global variable.
    – Jos
    Feb 22, 2019 at 17:47
  • So what I need to do? I hven't done anything in the code.
    – Naveen
    Feb 22, 2019 at 18:00
  • I googled the error and found this: wordpress.org/support/topic/menu-nav-page-error . Perhaps you could upgrade to a newer version of Woocommerce?
    – Jos
    Feb 22, 2019 at 18:11
  • I do not have a woocommerce plugin
    – Naveen
    Feb 25, 2019 at 6:40
  • This is actually fixed. it was causing another plugin, so I just disabled that plugin and it is working now.
    – Naveen
    Jul 30, 2019 at 11:57

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.