0

I can't use port 80 in my college and I need a mysql database and a version of wordpress for a college assignment. So when I change from port 80 to 801 (Or any port) I can't access Wordpress. I tried editing my Wp_config file, the wp_options database but each time wordpress defaults from localhost:801 back to localhost. Any ideas how to fix this? or another portable alternative to uWAMP? Any help would be appreciated.

  • If you're running this on your local machine, you should be able to configure your system to respond to port 80. Let's assume that's not possible, though. WordPress does not care which port you use. It's your local apache configuration that cares. You may need to change your apache config to use a different port for this website. – MikeNGarrett Feb 21 '19 at 17:04
  • Thanks for the response. I have to demonstrate it running on the colleges machine, which won't allow port 80 access. I've been looking in my apache config for any reference to wordpress or port 80, but I can't see any. I'm not even sure what to look for. – Anthony Gallagher Feb 21 '19 at 17:40
  • Oh! Ok. I'll post an answer with more details. – MikeNGarrett Feb 21 '19 at 18:15
0

Your apache config for this site should have something that looks like this:

<VirtualHost *:80>
    # The primary domain for this host
    ServerName example1.com
    # Optionally have other subdomains also managed by this Virtual Host
    ServerAlias example1.com *.example1.com
    DocumentRoot /var/www/html/example1.com/public_html
    <Directory /var/www/html/example1.com/public_html>
        Require all granted
        # Allow local .htaccess to override Apache configuration settings
        AllowOverride all
    </Directory>
</VirtualHost>

To change the port Apache is listening to, modify the *:80 to the port of your choice.

To change the ports open to the public, you may need to change the configuration for your firewall other systems.

Here's a decent tutorial related to getting WordPress set up correctly: https://www.linode.com/docs/websites/cms/configure-apache-to-run-multiple-wordpress-sites-on-one-linode/

  • Thanks for the help. I had edited the *:80 port to a different port and I reinstalled wordpress, but I was still having the same issue. I installed Joomla while on that port no issue, so I will just use it. – Anthony Gallagher Feb 21 '19 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.