0

Since WordPress 5 is out im wondering if there are still security updates for WordPress 4.9.9 or do I need to update to WordPress 5 as soon as possible?

  • Since there are stable 5.1 release candidates and have also already had security and maintenance patches for 5.0 I'd just upgrade and use the classic editor plugin if you need to. – Aravona Feb 18 at 9:24
  • 1
    Krzysiek's answer is correct, but some extra clarification: There is no "WordPress 5" or "WordPress 4". There is WordPress 4.9, WordPress 5.0 and WordPress 5.1 etc.. Each are 'major' versions of WordPress. There is no division between the 3.X, 4.X or 5.X versions. They're just the versions that came after .9 of the previous number. – Jacob Peattie Feb 18 at 11:14
2

According to Codex:

The only current officially supported version is WordPress 5.0.3. Previous major releases before this may or may not get security updates as serious exploits are discovered.

So, as you can see, the official version is that only the newest version is supported and only that version guarantees that you'll get security updates.

But if you'll see at history, most of the times, previous version also gets security updates.

On the other hand, if you want to postpone this update because of Gutenberg (Block Editor), then you can always use this question and disable it: How to disable Gutenberg editor?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.