0

Wife transferred her domain from Godaddy to HostGator. Somehow the Post page is still linked to the old site. I say old site because she started fresh on the site only wanting the domain. Her domain was hersite.wordpress.com and now is just hersite.com.

All the content is where it should be until I assign the post page. No matter what page I set to be the post page for her blog it automatically wipes everything form that particular page except the header. Once I switch the post page settings back to "select" or none, the content is back to normal. What she didn't tell me was two weeks ago she was able to log into the old site and everything was the same except the blog ( set at post page ) was all from the new site. Sorry for the 3rd grade explanation of the issue. How do I fix this?

0

I think this can be the cause from some permalink settings. In the Settings-> Permalinks, you can click the "Save" button, and the permalinks will refresh. I'm not sure that will work, but that's where I will first look.

|improve this answer|||||
  • Yeah, thanks for replying. I've been down that road and like 200 others. I saw that the old site was actually getting the post pages. URL issue maybe? – Chris Feb 17 '19 at 7:42
  • There can be also an .htaccess issue, if you can look into error logs and see if there is something about this. – Brada Feb 17 '19 at 8:36
0

Maybe a search/replace plugin (I like "Better Search and Replace") to search for https://www.olddomain.com and replace it with https://www.newdomain.com .

Which will also fix broken URLs for files in the media area (pix, etc).

Added

Check the wp-options table for the two URL entries. Make sure both are set to the new value.

Then look at the wp-config.php file and check for the wrong URLs in constants there. (Which is why I don't like making those URL changes in the wp-config.php file...)

|improve this answer|||||
  • Thanks Rick. I did try your suggestions and still the same issue. Entire site is operating correctly as far as I can see, except the blog page. – Chris Feb 19 '19 at 2:02
  • See added info in my answer. – Rick Hellewell Feb 19 '19 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.