0

I moved my WordPress installations from my old server to a new one. I copied all databases..etc and things seem to be working fine. (I have already migrated servers before, so I guess I know how to do the migration part correctly). However I only have one problem with ALL my wp installations, when adding new items to navigation menu, the “add to menu” doesn’t work. This video illustrates my problem: https://drive.google.com/file/d/1hEa2lNkavCm-EFfU7Ct8c88LOhRH9vl1/view

I even did a new test installation from scratch just to see if the problem is due to copying files from another server, but I still have this issue with the new installation. So I guess it might be a server issue?

When I click add to menu the page reloads(which is unusual) then this appears in my console:

"[Violation] Added non-passive event listener to a scroll-blocking ‘touchstart’ event. Consider marking event handler as ‘passive’ to make the page more responsive. See chromestatus.com/feature/5745543795965952

" in load-scripts.php I tried changing these in my php.ini

post_max_size 20M
max_input_vars 10000

But it didn't solve the issue, however now nothing appears in the console.

I tried clearing my browser cache and the .htaccess file and I already have the following in my wp-config right before "that's all stop editing"

define('WP_DEBUG', true);
define( 'CONCATENATE_SCRIPTS', true );

define( 'WP_MEMORY_LIMIT', '256M' );

The old server uses mariaDB 5.5, the new one uses 10.2, I’m not sure if this is related to the problem though…

Can anyone suggest a solution for this? Hope someone can help me 🙂 And thanks in advance

2
  • Using the developer tools in your browser look at your console and/or network panel and see if there are errors. I suspect there may be error'/s in 'admin-ajax.php' Let me know what you find if anything.
    – Beaniie
    Feb 16 '19 at 15:13
  • nope, nothing appears in the console after I modifed my php.ini (as stated in the post) but before the php.ini I had this message in my console when clicking on add to menu: "[Violation] Added non-passive event listener to a scroll-blocking ‘touchstart’ event. Consider marking event handler as ‘passive’ to make the page more responsive. See chromestatus.com/feature/5745543795965952" in load-scripts.php
    – user206904
    Feb 16 '19 at 15:51
0

Try looking at the following areas to try and debug;

  1. First and foremost, flush the cache for the url, either by hard reload cmd/ctrl + refresh > Hard reload. Or via any caching plugin you may be using.
  2. Use the inspector to look at the console, when changing items in the backend and loading the page initially. See if there are any errors.
  3. Try setting the CONCATENATE_SCRIPTS to true in your wp-config. define( 'CONCATENATE_SCRIPTS', true ); // remove this if it doesn't solve your issue.
  4. Check your .htaccess file isn't corrupted. Copy the file and name it htaccess-copy. Then delete all the text inside the ORIGINAL and save. Then go to “Settings > Permalinks” and try re-saving your permalinks.

Let me know how you get on. :)

3
  • Hey, I will modify my post to include more details on what I have tried, but yes, I already tried all of these and tried these again now that you told me to do it.
    – user206904
    Feb 16 '19 at 15:56
  • What is "the inspector"? Something in Firefox? Feb 16 '19 at 19:44
  • The inspector are the developer tools in chrome. developers.google.com/web/tools/chrome-devtools
    – Beaniie
    Feb 16 '19 at 19:48
0

I figured it out. It's not a Wordpress bug. I had sentora panel installed on my server. Sentora uses a module called suhosin.

The problem was Suhosin. Suhosin v 0.9.37 has a bug with Wordpress. I upgraded to version 0.9.38 following these instructions: http://forums.sentora.org/showthread.php?tid=4131&pid=30287#pid30287

Everything works fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.