0

Today I updated (locally) one of my sites from version 4.9.9 to 5.0.3 using WP CLI ($ wp core update --version=5.0.3). The update ran successfully but I have noticed two things.

  1. Gutenberg did not automatically get added into core. I had to install it manually from Plugin installation page

  2. Before update the system was using WordPress's default classic editor. Now with Gutenberg activated, I want to make it the default. When I went to Settings > Writing I don't see the Default Editor selection option.

My problem is regarding #2 above. How can I make Gutenberg the default editor?

The application I am working on was not developed by me. I have been asked to convert a few shortcodes into Gutenberg block. For this I need the Gutenberg editor as the default one.

closed as off-topic by Krzysiek Dróżdż, Jacob Peattie, Nathan Johnson, rudtek, cjbj Feb 11 at 8:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that are too localized (such as syntax errors, code with restricted access, hacked sites, hosting or support issues) are not in scope. See how do I ask a good question?" – Krzysiek Dróżdż, Jacob Peattie, Nathan Johnson, rudtek, cjbj
If this question can be reworded to fit the rules in the help center, please edit the question.

1

The block editor (formerly known as Gutenberg) is the default editor. You should not need to install the plugin or choose an option to make it the default.

The plugin is now just for following and testing future developments, and the Settings > Writing option only appears if you're using the Classic Editor plugin.

The only reasons I can think of that it wouldn't already be the default editor are:

  • The Classic Editor plugin, or similar, is activated and enabled.
  • You're using a page builder plugin — or a theme with a bundled page builder — that disables or bypasses the block editor.
  • You are editing a custom post type that does not support the REST API (show_in_rest needs to be true).
  • Your host is forcing it to be disabled. Check for a wp-content/mu-plugins directory and see if it contains a file that sounds like it would do this.
  • You have otherwise added code, via plugin or theme, that disables it. Try disabling your plugins one by one until the proper editor appears.
  • You're not actually running 5.0.3. Check the bottom right corner of the admin. It should say "Version 5.0.3".
  • Thanks for explaining so clearly. I will check one by one. The version by the way is Version 5.0.3. – Subrata Sarkar Feb 5 at 13:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.