0

I did this:

cd wp-content/themes
cp -R someTheme newTheme

then:

cd newTheme
vim style.css #changed name of theme in the css comment header

and then logged into example.com/wp-admin. But when I looked at the list of themes (under the appearance header in left menu), I did not see it there. What else must I do for wordpress to notice my theme?

wp version = 3.0.4

  • I have multi-site enabled. See my answer below – Alexander Bird Nov 3 '11 at 5:08
1

I have Multi-Site enabled.

That means I must first log in as a super admin, then go to "super admin" > "themes" option in left menu (inside wp-admin), and then enable it there first.

0

Your theme needs at least an index.php file for WP to recognize it, along with the style.css file. The style.css file doesn't technically need the name, author, etc., WP will use the directory name if it's missing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.