0

Eveytime I want to upload an image I get an HTTP error. When I check for the image on the server though I can see that it has been uploaded. Only variations of the file of different sizes which seemingly get created upon the upload of the original image, seem to have 0 bytes (this may be due to the HTTP error?)

Also; another question: After uploading an image, in my woocommerce theme the image in my shop just looks too big or rectangular of different dimensions. Doesn't woocommerce automatically resize and adjust the images to they look all the same when previewing them in the shop?

There is an option somewhere where you can say that you want the image to be resized but once you do, the image will look low quality and parts of it will get cut out etc.

How do I go about uploading images of the product so that it will be all shown in the same square dimension in my shop?

0

For fixing HTTP error, follow these steps:

  1. Open the cPanel.
  2. Go to File Manager.
  3. Search for wp-content.
  4. Find uploads folder. Right-click on it and choose Change Permissions.
  5. A pop up will appear. Set the permission to 755.
  6. Finally, click on the Change Permissions button. You will find that the HTTP error has gone.

You can find more information about these steps right here.

Regarding too big images issue, add these CSS codes in the Custom CSS Box provided through the Customizer Options:

.woocommerce #primary .images img {
    width: auto;
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.