1

How can I enable xmlrpc in WordPress 5? I followed some tutorials related to this topic, but I didn't find the check box in the Settings writhing panel.

I got 403 Forbidden Access after every request.

Thanks.

2
  • 2
    It should be accessable by default. Maybe your host is blocking it or one of your plugin?
    – birgire
    Jan 22, 2019 at 17:11
  • 1
    Can I ask why you're trying to enable XMLRPC? You should use the REST API if you're trying to make requests in code
    – Tom J Nowell
    Dec 12, 2019 at 2:52

3 Answers 3

2

What are you trying to do?

XML-RPC is enabled by default.

XML-RPC functionality is turned on by default since WordPress 3.5.

In previous versions of WordPress, XML-RPC was user enabled. To enable, go to Settings > Writing > Remote Publishing and check the checkbox.

Try going to http://example.com/wordpress/xmlrpc.php, your should see a message saying "XML-RPC server accepts POST requests only."

Source

3
  • the access is denied, i got this message when i try to reach the xmlrpc.php file Error 403 Jan 22, 2019 at 19:01
  • Do you have something in your .htaccess like <Files xmlrpc.php>... or code like add_filter('xmlrpc_enabled', '__return_false'); in your functions.php or plugin? Jan 22, 2019 at 19:47
  • Also, check what you have in wp-admin > Settings > Writing > Update Services? If you have your site set to discourage search engines in Settings > Reading this option will be disabled. By default you should have "rpc.pingomatic.com" Jan 22, 2019 at 19:53
0

It could be that your hosting service is blocking those URLs for security reasons. Depending on the use cases, you might be able to rename the PHP file to something like XxnYtGkwuThOpws.php and use it as expected...

1
  • That's probably worth trying to diagnose the problem, but the rename might get lost on a WordPress upgrade so it's not a long term solution. If that is it then you need to talk to your host, or switch to the REST API instead.
    – Rup
    Feb 13 at 13:03
-2

Updated WordPress is not working default xml-rpc but you can on/off manual follow my procedure:

1st install this plugin: WP Htaccess Editor

Then paste this code correctly without any spaces:

<Files "xmlrpc.php">
Order Allow,Deny
allow from all
</Files>

See the screenshot below SCREENSHOT

1
  • Hello & Welcome to WordPress StackExchange! This answer was flagged as an undisclosed affiliation by linking your website at the end of your answer. Promoting something you've written (such as an "how-to" article) is fine but not your general website. For more information please review Promotion and take the site tour.
    – Howdy_McGee
    Dec 12, 2019 at 4:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.