0

I do have the same issue as in here. Since I can't leave a comment and so I post another new topic for help. Does anybody else can solve it? I come across the same issue suddenly. I haven't tried to add 'post_status' => 'publish' to arg as it is not a workable way for me since I do not know when and how many of my user writing a "future" post. I can't teach them to add that to arg one by one for everytime when do making a scheduled post, they are a typical end user, no coding. Besides, it should be a default feature that should be working without extra effort.

0

Check your server time and check time from WordPress Settings >> General and check your time zone there.

Install the Health Check plugin, run it, and check what it says about WP-Cron.

Remove this define('DISABLE_WP_CRON', true); code from the wp-config.php file. Also, Contact your hosting provider regarding this issue :)

  • Thanks. I installed the health check plugin but I couldn't find any part for wp-cron. I thought it is because I just checking in one of the subsite, but when I activate in network level, I can't even find the health check info page. BTW, I quite sure the cron task in my site is working fine and the problem is not the scheduled post not appear on scheduled time and it show instantly. So should I still focus on cron issue? And the time zone setting is correct too. Please advise, thanks a lot. – Anfield Jan 23 at 7:20
  • can you try after disabling all activated plugins? – Arvind Singh Jan 24 at 18:15
  • ok thanks. Found one of our plugins causing the scheduled post problem. =) – Anfield Jan 29 at 9:53
  • aah !, that great :) – Arvind Singh Jan 29 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.