0

This the email i received from a subscriber, i am not sure how to prevent multiple emails from going out.I do not use a plugin just the WordPress native comment mamagent

“Notify me when new comments are added” checkbox and now each time a comment is added I get four e-mails with the same comment. Is there any way you can remove people from that service?

0

Although it would be useful to determine why the extra notifications are sent (forwarding settings?), there is a way to adjust who gets notification emails when a comment is posted (which is what you asked, not how to fix the problem):

// adds emails to the 'notify admins on comment submit'
// from http://www.sourcexpress.com/customize-wordpress-comment-notification-emails/
// must be enabled via Settings, Discussion, "Email me whenever Anyone posts a comment" 


function ss_comment_moderation_recipients( $emails, $comment_id ) {
    // Email notification only to the admin
    $emails = array( get_option( 'admin_email' ) );
    $emails[] = "anotherperson@example.com";
    $emails[] = "morepeople@example.com";
return $emails;
}

add_filter( 'comment_moderation_recipients', 'ss_comment_moderation_recipients', 11, 2 );
add_filter( 'comment_notification_recipients', 'ss_comment_moderation_recipients', 11, 2 );

The $emails array is an array of emails to send to. The code above gets the admin_email email address, then adds two emails to it. The two add_filters are needed to ensure it works.

Based on the answer here: http://www.sourcexpress.com/customize-wordpress-comment-notification-emails/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.