0

I've been working on a wordpress site (geniedrinks.co.uk) using the Jevelin theme. Last night, I deactivated a plugin called WP Bakery Page Builder (js_composer) which immediately resulted in HTTP error 500 across all pages - I can't even access my wp-admin page.

I have a feeling reactivating the plugin might correct the issue, but can't find a way to do so from within the control panel (server host is names.co.uk). I've looked for an options tab within PHPMyAdmin to try and find a list of active plugins (to add the plugin manually to the list), but can't locate said tab. Any help or alternative solutions gratefully received.

Many thanks in advance,

Nic

1

You can do this by editing the database via PhpMyAdmin.

Go to your database's Options table and find a row called active_plugins.

You should see something like this...

a:10:{
    i:0;s:49:"1and1-wordpress-wizard/1and1-wordpress-wizard.php";
    i:1;s:29:"acf-repeater/acf-repeater.php";
    i:2;s:30:"advanced-custom-fields/acf.php";
    i:3;s:45:"limit-login-attempts/limit-login-attempts.php";
    i:4;s:27:"redirection/redirection.php";
    i:6;s:33:"w3-total-cache/w3-total-cache.php";
    i:7;s:41:"wordpress-importer/wordpress-importer.php";
    i:8;s:24:"wordpress-seo/wp-seo.php";
    i:9;s:34:"wpml-string-translation/plugin.php";
}

You can add a new row for your plugin. You will need to know the following.

  • a:10 : 10 = the count of row (how many plugins are in the list)
  • i:0;s:49 : i = the item position in the list
  • i:0;s:49 : s = the character count

So you you can activate a new plugin by adding a new row and change the values like this...

a:11:{
    i:0;s:49:"1and1-wordpress-wizard/1and1-wordpress-wizard.php";
    i:1;s:29:"acf-repeater/acf-repeater.php";
    i:2;s:30:"advanced-custom-fields/acf.php";
    i:3;s:45:"limit-login-attempts/limit-login-attempts.php";
    i:4;s:27:"redirection/redirection.php";
    i:6;s:33:"w3-total-cache/w3-total-cache.php";
    i:7;s:41:"wordpress-importer/wordpress-importer.php";
    i:8;s:24:"wordpress-seo/wp-seo.php";
    i:9;s:34:"wpml-string-translation/plugin.php";
    i:10;s:20:"my-plugin/plugin.php";
}
  • Thanks for your help. I've followed your instructions but unfortunately this hasn't resolved the issue. In the meantime I've also enable debug mode so there's more detail available now showing - please see geniedrinks.co.uk - am i right in thinking the issue is with the theme rather than the plugin? any pointers to solve this via ftp? (i'm still waiting to hear back from the theme developer). Thanks again. – Nic Higson Jan 16 at 21:40
  • try disabling all your plugins, see if that works. Then try switching to a default theme like twentysixteen or something. – RiddleMeThis Jan 16 at 21:42
  • awesome - i'm back online - it was a theme issue. thanks so much for your help. – Nic Higson Jan 16 at 21:59
0

You can deactivate all other plugins by renaming the plugin directory to a temporary name. Also try to deactivate the current theme by renaming its directory so Wordpress falls back to the default theme.

After you login to the dashboard, rename the directories again to their original then activate the plugins one by one.

Later if you want to troubleshoot issues, use Health Check plugin to help you detect if any plugin or theme has bugs without the need to actually deactivate or activate it which may break your site. It's very helpful for debugging and troubleshooting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.