0

when i update my site from php 5.6 => 7.3.0 . i recviced this error 'Error establishing a database connection'..

But when i downgrade php to 5.6 , my website work fine . Anyone know this issue . this is my php 7.3.0 configure

'./configure' '--with-apxs2=/usr/bin/apxs' '--with-bz2' '--enable-calendar' '--with-curl' '--enable-exif' '--enable-ftp' '--with-gettext' '--with-pcre-dir' '--with-pdo-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--enable-mysqlnd' '--with-pdo-sqlite'

0

Old versions of mysqlnd worked with legacy database passwords. I had to update the database to use more secure password format before the mysqlnd plugin would connect from Wordpress 5.0.3 to php 7.3

PHP Warning:  mysqli::__construct(): (HY000/2000): mysqlnd cannot 
connect to MySQL 4.1+ using the old insecure authentication. Please use an 
administration tool to reset your password with the command 
SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, 
and more secure, hash value in mysql.user. If this user is used in other 
scripts executed by PHP 5.2 or earlier you might need to remove the old-
passwords flag from your my.cnf file in /root/db-test.php on line 2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.