I'm trying to login to one of my Wordpress sites through the /wp-login.php link. When submitting the login form the page refreshes but does not re-direct to the /wp-admin.php dashboard.

I've tried typing an incorrect password (to check if the login details are wrong) and I do get an "incorrect password" message as expected, however when I type the correct details no error messages are displayed.

I've attempted to reset the password through the "Forgot password" page, but I get the following error message:

"Could not save password reset key to database."

The site is hosted through AWS's Elastic Beanstalk with an Amazon Aurora instance powering the DB. When attempting to reset the password through MySQL I am hit with a "Read Only" error.

All posts are being loaded from the DB correctly, so I know it's not an issue with the DB presenting data in response to a query.

I've cleared all cache and cookies for this in the hope that it was just a cache/cookie conflict however I'm still not able to login through any user account on the WP install.

The site was working fine a few days ago and nothing has been changed since then - No new posts, no updates etc.

Has anyone experienced this before and how can I fix it?


1 Answer 1


These issues all point to data not being saved to the database - As prompted by Stefano Tombolini's comment on the question, I changed the database connection host.

The cause of this issue is that I had originally connected to an instance inside of a database cluster rather than the cluster itself. Occasionally the instances in the cluster change role between reader and writer. This caused the instance that I was connecting to to be read-only.

See this post about solving this issue: stackoverflow.com/questions/46665588/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.