5

I am currently using Wordpress version 5.0.2, i want to add news posts but the button "ADD BLOCK" is not active.

enter image description here

1
  • this is because you are not in the visual block editing mode. This could be because you disabled the visual editor, a JS error in the browser dev console, or because you are in the code editor mode
    – Tom J Nowell
    May 12, 2023 at 17:51

5 Answers 5

7

I think you have the visual editor disabled.

Go to Users > Your Profile and uncheck "Disable the visual editor when writing".

enter image description here

5

I Had the same issue. Followed RiddleMeThis' suggestion but "Disable the visual editor when writing" was not checked.
I checked it, Updated my profile then unchecked it and updated my profile again and the issue was solved.

1
  • I tried your suggestion but it's still disabled. It's frustrating because WordPress knows why it's disabling it but doesn't want to let the user know. :'( May 26, 2020 at 12:03
3

In my case this was caused by WordPress requiring User-Agent header present, which AWS CloudFront CDN by default do not pass (and in most cases due to performance reasons, should not).

My workaround for this, as described in AWS CloudFront Configuration for WordPress/WooCommerce - About Lovia:

WordPress/WooCommerce requires User-Agent header to be passed by CloudFront in order to enable the visual editor. There are several ways to work-around this, but our best practice is to add additional behavior for path pattern /wp-admin/*.

AWS CloudFront Configuration for WordPress/WooCommerce - About Lovia

Note: "Disable the visual editor when writing" must be unchecked.

Additional info: https://wordpress.stackexchange.com/a/325234/184905.

1
  • Thank you for your answer. I had a similar issue with AWS Amplify, which is used with Cloudfront distribution but doesn't let changing its settings directly. So I ended up overwriting user agent directly in wp-config.php. But you answer helped a lot for me to go into the right direction.
    – senya
    May 12, 2023 at 16:22
1

For others facing this issue, it occurred for me after adding a new user via phpMyAdmin but omitting the nickname field. Adding this field under my profile, and saving then enabled the block editor.

1
  • My user profile already had a nickname, I tried changing it to something else but still disabled. May 26, 2020 at 12:04
1

I had the same problem as the author of the question.

The answer from Hendy Irawan directed me to the solution, but in my case it was a little different than his, so I'm posting it as a separate answer.

I use Wordpress on AWS EC2 instance hidden behind AWS Amplify, which rewrites some of the requests to point them to the Wordpress installation. AWS Amplify uses Cloudfront distribution internally so it overwrites the User Agent header of any request to Amazon CloudFront. However AWS Amplify does not allow changing Cloudfront distribution directly.

So what I did is that I added the line to wp-config.php to overwrite and to set a fixed value for HTTP_USER_AGENT on any request:

$_SERVER['HTTP_USER_AGENT'] = 'Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/113.0.0.0 Safari/537.36';

This will essentially make Wordpress believe that any HTTP request it serves is coming from the web browser with the specified user agent value. Thus it'll make all features work like if you requests it from that browser even if you're requesting from something else.

Personally I believe that such solution is fully acceptable because relying on User Agent value in web software as a way to decide which features are available is discouraged and considered to be an anti-pattern in web development. So blinding Wordpress from seeing browser difference seemed like the right thing to do in respect to this particular issue I had. However I cannot guarantee there won't be any undesirable side-effects in a more generic cases, but it worked pretty fine for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.