0

Earlier I updated several wordpress plugins. One of those updates broke my access to wp-admin. So, I restored the backup I made prior to updating the plugins. At first I could not access wp-admin due a cookie issue. I resolved that by adding these lines to my wp-config:

define('ADMIN_COOKIE_PATH', '/');
define('COOKIE_DOMAIN', '');
define('COOKIEPATH', '');
define('SITECOOKIEPATH', '');

I can now access wp-admin, however whenever I do, I get a message at the top of the screen saying:

you need to configure http://mysite

By default my website is https://mysite, but on the wp-admin settings page it just lists it as http://mysite. What/where do I need to make a change to remove that error?

My other problem is that I cannot access my network dashboard. Whenever I try, it changes the URL from https://mysite/wp-admin/network to https://mysite///wp-admin/network and I get this error:

enter image description here

I use CiviCRM and I cannot access the CiviCRM dashboard. I get this error:

enter image description here

and the civi menu doesn't display. I have a subsite and from the subsite's dashboard, I can access Civi, but I get the same error when I try to access the network dashboard.

What do I need to do to regain access to the network dashboard and Civi?

I'm using Wordpress 4.9.9 and CiviCRM 5.4.1.

  • Have you contacted CiviCRM support? Which plugin broke the site on update? Note that we don't provide support for 3rd party plugins here – Tom J Nowell Jan 8 at 19:15
  • Yes, I know you don't provide support for 3rd party plugins. The main reason I posted here is because I cannot access the Wordpress Network dashboard. I added the civi info just in case there was someone here who uses civi and has seen this before. There is no CIviCRM support since Civi is free. – kzburn Jan 8 at 19:41
0

Access your plugins folder via FTP or your Hosting cPanel "Files" program. Rename the offending plugin folder to something else. That will effectively disable the plugin. (If locally hosted, then change the folder name that way.)

I don't usually change the settings in the wp-config.php file, so you may want to put those back to original.

Then use your phpMyAdmin program (via your hosting Control Panel if needed, or your local equivalent if locally hosted) and access the wp-options table. There are two locations in there for the site 'home' URL. Change both to the same value (to https://mysite , if I go by your example)

That should allow you to get back into the admin area, and you can go from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.