0

I used BackupBuddy to revert the database and overwrote the wordpress files of version 5.0.2 with 4.9.9. However I can't use the admin without the Database Update Required screen blocking me. How to i stop this upgrade from happening?

  • Alternatively, you can disable automatic updates in WordPress by adding this line of code in your wp-config.php file: 1 define( 'WP_AUTO_UPDATE_CORE', false ); – vikrant zilpe Jan 3 at 12:12
  • Have you considered using 5.0 but using the classic editor plugin? You don't have to use the new block editor with 5.0 if it isn't for you – Tom J Nowell Jan 3 at 12:16
  • To clarify I think the issue is caused by left over files (perhaps an upgrade trigger) from 5.0.2 that are not normally there for 4.9.9. It is not an automatic security update it it is some something telling wordpress the database needs to be upgraded even though I've replaced the files with 4.9.9 and downgraded the database. – snowliondev Jan 3 at 12:25
-1

You are facing the issue due to the different database versions. Please, follow this steps to fix the issue:

  1. Head to /wp-include/ folder.
  2. Open the version.php file.
  3. Find the value for $wp_db_version.
  4. Open your database. Find wp_options.
  5. Use the following line to identify the value of db_version:

    SELECT option_value FROM yourdatabase.wp_options WHERE option_name = 'db_version';
    

The values of $wp_db_version and db_version must be the same. Make sure that you make the change in the version.php file, but not the database.

  • Don't edit core files. – Jacob Peattie Jan 3 at 12:31
  • Strange but the values are already the same – snowliondev Jan 3 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.