0

All was not lost, fortunately, but because I had an old copy of the website and database and used a local server I was able to determine the culprit behind the loss of all my recent changes. I was about to download the latest version of the website when this happened, but a failed Jetpack update ruined my chance to backup my site.

A day earlier I got some errors trying to do plugin updates. I returned today to do a backup of the site. Loading the site revealed a mess. Much of the theme's structure was not working. (I had not tried to update the theme) Before downloading a backup copy I wanted to update everything. I got to Jetpack and there was an error. There was a ".maintenance" file in the root folder so I got the maintenance message. I deleted that and got a "Page is Not Working" message. I played around with using and not using the .maintenance file. I decided to download the site as is. I moved the old/local one elsewhere. I downloaded the files and exported/imported the database (had exported the old database and saved it), ran the queries to fix the directory paths in the database, and replaced the wp-config.php file with the local one.

I tried to open the site expecting to get the same results, but even though it did not work, my effort was not fruitless. I got the specific error message in the browser that related to a critical missing file in the Jetpack plugin folder. "No problem, I'll just replace the Jetpack folder with the old Jetpack folder, I haven't updated it since the previous backup anyway." So, I copied in the old one.

The site came right up, but GD IT!!! It is the old version of the site. I had made a few major changes and even though I had downloaded the current files and the current database, all my changes were gone. A new page was missing and a new plugin was missing... along with other, minor changes.

That looks to me like my website had been hanging by a Jetpack-Thread and all it took to lose everything since my last backup was an error updating that plugin. When I hit delete of the current Jetpack folder, I noticed the display showed a file count of something over 300 files being deleted. When I copied the old Jetpack folder in there, there were more than 1500 files in there. Looks like the update error kept the new plugin files from being created and those files were critical to the existence of my website.

If I did not have that old backup, I would have lost the whole website because of a stupid plugin. At least, that's what it looks like to me. Is there no way to salvage all my recent changes? Were they lost with the lost Jetpack files? Does a website become utterly dependent on Jetpack once it is installed? The site was working fine yesterday before my first plugins update attempt.

If someone would like to elaborate on the subject I am all ears and if so, thank you very much!!

migrated from superuser.com Dec 26 '18 at 9:25

This question came from our site for computer enthusiasts and power users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy