0

I am working on deploying wordpress on my personal server just to learn a little bit more about it. I have made it all the way to the admin page but when I try to customize a theme I get a 403 error

You don't have permission to access / on this server.

I have set all folders to 755 and all files to 644 permission. Is there some other security issue that I may need to change maybe in .htaccess? I am running Ubuntu 16.04, apache2, wordpress 5.0, and php 7.3.

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
4
  • 1
    try removing current htaccess file temporary – Vishwa Dec 18 '18 at 5:55
  • I did a2dismod security2 and everything is working fine now. Any idea where I can find some security2 settings so I can still run it but not have issues on my site? – Chris Wendel Dec 18 '18 at 6:18
  • you should post .htaccess code also – GHOST Dec 18 '18 at 6:30
  • Added my .htaccess – Chris Wendel Dec 18 '18 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.