I know that a similar question has been asked before, but this is NOT a duplicate because this is specific to Wordpress 5+ and the answers to the similar question have all been tried to no avail.


My Wordpress is Version 5.01 and there are some technical issues PHP error logs indicate the core WordPress needs to be reinstalled (bad syntax errors on core SQL queries with empty $vars) .

However; when presented with Re-installing Wordpress on the admin area; it states that:

Another update is currently in progress

I have run through all of the answers in this question and they are invalid or not applicable (they have all been attempted to confirm this):

  • The .maintenance file has been manually disabled.
  • The <...>_options table directory does NOT contain the wordpress update .lock tag. Despite this being confirmed as appearing in the PHP code.
  • All plugins have been disabled.
  • The lock does not time out and resolve after 15 minutes.

Yet I am still unable to find either the cause of the notification or the notfication itself in the PHP code, to manually override it (reference here again) .


How do I over-ride the "Another update is currently in progress" in WordPress 5. This request is specific to WP5 as it appears the system may have changed since before 5.0,


I am not looking [just] for how to work-around the problem; more an explanation as to how the text "Another update is currently in progress" is generated on WordPress 5

Thank you for any guidance on this.

  • Just noting that I've been running into this too and fixed it with a manual update, as suggested by @Keonramses. However after the manual update, if I attempt to update using the dashboard again, the update will get stuck on Disabling Maintenance mode" and If I then try yet another update from the Dashboard, I'll get *Another update is currently in progress which I can resolve by deleting the core_updater.lock option. This is happening on my Windows dev machine running XAMPP 5. Long story short; manual update fixes it for me but I'm not exactly sure what the cause is. – Dave Romsey Dec 18 '18 at 1:39

you can try doing a manual update, so as long as you didn't make any changes to the WordPress core files(if you did I suggest you take note of them and reapply after the upgrade), just head over to WordPress.org download the latest WordPress package and copy it over to your root folder on the server make sure you overwrite only the core WordPress files, leave the wp-content folder out of this, input your details to the wp-config.php file and that should probably sort this issue out for you. PS. remember to back up your database and original WordPress folders before continuing.

  • Hello, thanks yes I'm aware of the manual update but didn't know if there was anoither tweak/method I could perform to cicumvent this need. Thanks. +1 – Martin Dec 18 '18 at 10:59

You'll get this error also if WP can not insert a lock in the wp_options table. It may be that the table is not configured correctly, e.g. when copied from another source. The option_id should be autoincrement or the update fails. Check if can insert a lock entry in the database manually:

INSERT INTO `wp_options` (`option_name`, `option_value`, `autoload`) VALUES ('core_updater.lock', '1', 'no');

If the option_id is not autoincrement and this query fails, you'll need to make the option_id field autoincrement. You may need to remove the index in this field before making it autoincrement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.