2

Was playing around with settings and changed HTTP to HTTPs. I'm now getting a message that says "Index of /". Any idea how to change it back to HTTP or login to the website?

  • The idea is to revert settings. It's impossible to guess what have you done to face the problem. – Max Yudin Dec 17 '18 at 8:50
  • @David Does your hosting uses a control panel, like for example DirectAdmin or cPanel? Check my answer, sometimes it's just a setting. – Remzi Cavdar Dec 17 '18 at 10:04
1

By default web servers / your hosting serves files from HTTPS from a separate folder. This means that there are actually two directories on the server for hosting your website files:

For example

  • public_html – the standard "public" folder for HTTP requests
  • private_html – the standard "private" folder for HTTPS requests (e.g. secure content)

I don't know if your web hosting uses a control panel like DirectAdmin or cPanel. Usually, you need to configure HTTPS to use the same directory for HTTP requests.

DirectAdmin:

Step 1: Login to DirectAdmin and Choose the "Domain Setup" Link
On the next page select the domain that you would like to make these changes for.

Step 2: Choose the Symbolic Link Option
On the following page that displays the directory options, choose the second option at the bottom to Use a Symbolic Link for data in both directories, then click Save:

After making this change public_html will both serve HTTP and HTTPS and you only need to upload your files to the public_html directory.

See for more info: https://my.fastwebengine.com/knowledgebase/131/How-do-I-disable-the-privatehtml-directory-in-order-to-only-use-the-publichtml-directory.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.