0

I have two sites running WordPress 4.9.8

On one site I can see "Store uploads in this folder" option on in Media Settings

enter image description here

On another site I cannot see "Store uploads in this folder" option in Media Settings

enter image description here

I am admin on both sites. Why it happens? How to make it visible on both sites? Thank you

2

While the other answers cover part of the answer (old WP install), it is important to note: The options appear, if one of the options is set. They are stored via the keys upload_path and upload_url_path.

Before:

enter image description here

Run (or add directly in the DB)

$ wp option set upload_path foo
$ wp option set upload_url_path bar

After:

enter image description here

As has been mentioned, these options are deprecated and shouldn't be used anymore.

  • Thank you. It is, in fact, the answer I was looking for. Curiously, I found nobody elsewhere to ask or answer this important question. If set improperly, this setting may break all WP. If it is hidden from settings, imagine how tedious it will be to find that it is set wrongly! – Boris Zinchenko Dec 8 '18 at 14:48
  • 1
    I've had my problems with this as well as we migrated a couple of sites where this was set and I only found out after ridicously long research. To address your concern: If it is set, it is visible. If it is not set, it should in most cases not be a problem – kero Dec 8 '18 at 14:49
1

IIRC the option was softly deprecated sometime in the past, but if you have an old install it will still be indicated that it should be displayed and let the user edit it.

The second site is probably newer

(answering the question literally, if you need to be able to change it and can not find the relevant option, just say so in the comments)

  • I appreciate your comment. As told, both WP are of the same version but running on different hostings. It is not managed WP, just plain cPanel in both cases. So, I m curious on the effect. I m comfortable to know that it is hidden in newer versions. – Boris Zinchenko Dec 8 '18 at 14:02
0

I think that the second site is running on a newer WordPress version, rather than 4.9.8. That's why, you are not seeing the "Store uploads in this folder" option in Media Settings. However, you are seeing it in the first site, as it is running on 4.9.8.

  • Thank you for the answer. As told, both sites run on the same version of WP. – Boris Zinchenko Dec 8 '18 at 13:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.