0

I’m trying to set up a multisite environment with subdirectories, but when I add a new site and then go to the dashboard of the new site, it shows a completely white page with the links to the different admin menus and the links all lead to a white page saying “File not found”.

Here is a screenshot of what the admin page looks like https://imgur.com/a/gRVEiX3

This is my htaccess file:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]
</IfModule>

# END WordPress

And this is my multisite section in wp-config.php:

define('WP_ALLOW_MULTISITE', true);
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'fresenia.man.poznan.pl');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);
  • It looks like there's no stylesheets loaded, but there's no info from your browser dev console/error console, and no PHP error log info to confirm that or why – Tom J Nowell Dec 4 '18 at 16:20
0

Just you need to put this code in .htaccess file

# BEGIN WordPress
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^(.*\.php)$ $1 [L]
RewriteRule . index.php [L]

# END WordPress

and this code in wp-config.php file

define('WP_DEBUG', false);
define('WP_ALLOW_MULTISITE', true);
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'fresenia.man.poznan.pl');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

It's working and tested code at my side.

  • 1
    Can you edit your question to explain why this fixes it so that the OP can understand how it works? Copypasta is handy but it teaches people nothing, and if another person with this issue comes along with slightly different needs, they might not be able to use this answer – Tom J Nowell Dec 4 '18 at 16:21
  • That let to the page not being found at all instead of just being faulty. I would be surprised too, if it anything to do with the htaccess or config settings, because I just copied them from the Network Setup in Wordpress – Marius Dec 4 '18 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.