0

I have migrated a word press site to a self hosted linux server. My front page and all other pages load however images are still pointing to my old server. My wp-login.php page also gives an error 500.

I've changed the siteurl and home in my database using mysql terminal to my new database.

I've also changed my PHP ini file to 512M

I can get images to appear if i change guid in the 'wp_posts' table.

EDIT:

enabling debug showed the following:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Translation_Entry has a deprecated constructor in /var/www/MYSITE/wp-includes/pomo/entry.php on line 14

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; POMO_Reader has a deprecated constructor in /var/www/MYSITE/wp-includes/pomo/streams.php on line 12

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; POMO_FileReader has a deprecated constructor in /var/www/MYSITE/wp-includes/pomo/streams.php on line 120

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; POMO_StringReader has a deprecated constructor in /var/www/MYSITE/wp-includes/pomo/streams.php on line 175

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; POMO_CachedFileReader has a deprecated constructor in /var/www/MYSITE/wp-includes/pomo/streams.php on line 221

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; POMO_CachedIntFileReader has a deprecated constructor in /var/www/MYSITE/wp-includes/pomo/streams.php on line 236

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; WP_Widget_Factory has a deprecated constructor in /var/www/MYSITE/wp-includes/widgets.php on line 544

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Acf has a deprecated constructor in /var/www/MYSITE/wp-content/plugins/advanced-custom-fields/acf.php on line 17
0

Enable wp debug and then visit your login, let me know what is says. https://codex.wordpress.org/WP_DEBUG

  • Updated my post, I'm guessing using PHP 7.2 is not supported by these plugins. – blu Dec 3 '18 at 17:16
  • If you have access to cpanel try setting PHP version to 7.0 or lower. But i would recommend to update plugins and theme to latest version. You can also access your website by changing name of folder of specific plugin or theme. This will deactivate it. – dado Dec 3 '18 at 17:19
  • Yes, updating word press to the newest version and updating advanced custom fields plugin fixed this issue. – blu Dec 3 '18 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.