Seems throughout the day my blog seems to show 404 page errors with no pattern. I have to manually change the permalinks from /blog/%scategory%/%postname%/ to default, then back to /blog/%scategory%/%postname%/ in order to fix the permalink issue.

This has been a problem for us for the past six months, and our site gets 10k views a day. While that is not a lot, it does give us a huge problem when at certain periods of the day we have a huge issue where none of our Posts work, yet Pages continue to work fine.

I have extensive conversation on this issue at this post (http://stackoverflow.com/questions/3506130/wordpress-permalinks-not-staying) where I have narrowed a few things down, and at this point I believe the sCategory Permalink is the issue. I need help understanding what is causing this issue, and more importantly fixing this so it never happens again.

ANY help would be greatly appreciated.

1 Answer 1


I stopped using that plugin a long time ago. I don't think you really need it anymore honestly. I just remember it did the same thing that I was able to do when I disabled it, so I stopped using it. I don't think its still supported by the developer either, so may be out of date.

I may be wrong, but then again I use the least amount of plugins as I can and build most things into my themes.

  • i hate using plugins as well. can you advise how i can use the same perm setup w/o the plugin? i'm confused how to do that while keeping the urls we have set up w/sCategory plugin. any help would be greatly appreciated.
    – Zach Smith
    Commented Oct 25, 2010 at 16:16
  • Is your Wordpress URL and your Site URL in General Settings set up right? You can set the /blog/ directory there so that WordPress uses a different directory, Once you set it to sitename.com/blog you can just use /%scategory%/%postname%/ in permalinks. codex.wordpress.org/Giving_WordPress_Its_Own_Directory If that doesn't help, perhaps this might be able to. 1stwebdesigner.com/wordpress/…
    – jaredwilli
    Commented Oct 25, 2010 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.