0

I've been with this problem for a couple of days and the truth is that I can not find a solution. I have added code manually in wp-header.php and now I need to delete these lines that it generates automatically

The lines I want to eliminate are:

<link rel="stylesheet" id="create-css" href="http://www.myweb.com/wp-content/themes/movil/create.css?ver=4.9.8" type="text/css" media="all" data-inprogress="">

<script type="text/javascript" src="http://www.myweb.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1"></script>

<script type="text/javascript" src="http://www.myweb.com/wp-includes/js/jquery/jquery.js?ver=1.12.4"></script>

thaks!!

  • 1
    What code did you ad manually? You shouldn't add scripts and styles to the header manually. – Jacob Peattie Nov 24 '18 at 10:46
  • We are trying to pass the web from http to https, but we do not know why those three codes are not edited and they always remain in http giving errors on the page. – LuisCG Nov 24 '18 at 10:54
  • What we have done is add those same three codes but with https manually and now we want to eliminate those that generates <?php wp_head(); ?> – LuisCG Nov 24 '18 at 10:56
  • you should remove what you have added manually and add https in the site url and home page url in settings. – Akshat Nov 24 '18 at 11:01
  • The whole web is already working in https, we have added the url in the configuration of the site, but those three codes are not edited and we do not know why it happens. That is why we have decided to add it manually in the wp-head.php and try to eliminate it from the <?php wp_head(); ?> – LuisCG Nov 24 '18 at 11:03
0

It sounds like you should backup your site first. Then go in to the editor under appearance, and find the file your looking for. Its usually under appearance on the dashboard.

Appearance > Editor

Then you can delete the files in question.

If they are styles and scripts, deleting them may break certain functions, or make your site look odd.

If you are hosting the stylesheets and scripts on your website, and you have converted all other links on the website, you should probably just add an "s" into the http:// protocol, changing it to https://

  • Hi. First thank you try to help us. I followed your instructions but we could not eliminate those three codes. Inside WP-Head.php we find the code <? php wp_head ();?> which is the one that general those three codes that we want to eliminate. – LuisCG Nov 24 '18 at 14:02
  • It would not be possible to eliminate them by adding some code like this in the fuctions.php ??remove_action('wp_head', 'wlwmanifest_link'); – LuisCG Nov 24 '18 at 14:06
  • Thanks for clarifying. It sounds like it may be a dependency of a certain plugin or possibly your theme itself. because wp_head pulls in a variety of things. I think you should try a plugin that tries to force https on all links, or test deactivating plugins/ themes until you find what is passing in the unsecure links. Then you could either leave it disabled or try editing it. It might be easier/safer to migrate the whole site to a local server to test configuration changes. – Tony Wheeler Nov 25 '18 at 1:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.