0

first of all big thanks to anyone willing to help, now to my issue:

When I change the wordpress language in general settings to anything but default (cs_CZ in my case) the texts are changed properly but the value of default language stays en_US.

wrong default value of language

I tried to google the issue, but no luck. Everyone else has issues with changing the language, but I dont - it just refuses to change the default value for some reason but still accepts the texts change.

What happens in general settings: 1. I click on the language version and choose Czech (English was preselected) 2. I click save changes 3. Texts in the wordpress changes to Czech language, but the language version resets to English for some reason.

general settings reset of language

I tried to play with wpconfig file, I set profile Languages to Czech. I triple checked that I have all Czech files uploaded etc.

I am starting to believe that the initial WP installation must be corrupted for some reason?

Any ideas how to fix this?

  • Disable all plugins and try again saving the site language. If disabling plugins doesn't help, try using a default theme. – Sally CJ Nov 22 '18 at 1:05
  • Thank you @SallyCJ, I will try this out in the evening. – Jake Nov 22 '18 at 8:34
  • No problem @Jake, and do let us know your findings. – Sally CJ Nov 22 '18 at 17:24
  • @SallyCJ I have disabled all addons - no change. I have switched the theme to default -> language in general settings switched to Czech as it should. With default theme it works fine. Thx for the hint. So now I know what causes issues - Divi template. I will try to dig deeper into it, but any suggestions what part of template could cause this would be a great help. Unfortunately I wasnt the one who created the website, but I am trying to fix the mess and I am stuck with the Divi template. – Jake Nov 22 '18 at 18:34
  • I got it! I have simply disabled translations for divi (in general divi template settings) and suddenly my default language is Czech as it supposed to be. Seems like their "automatically adapt with your WordPress language preferences" is quite buggy. Thank you so much for helping me out. – Jake Nov 22 '18 at 18:51
0

I got it! I have simply disabled translations for divi (in general divi template settings) and suddenly my default language is Czech as it supposed to be. Seems like their "automatically adapt with your WordPress language preferences" is quite buggy. Thank you so much for helping me out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.