2

I’m on WordPress 5 beta 4, the problem is that meta boxes can not hide them when selecting a specific template chosen by page attributes. To make them appear or hide, you have to update the browser page or exit the created page and re-enter it. This is not very nice for users. This is my code:

<?php
function willer_custom_meta_portfolio_standar() {
    global $post;

    if(!empty($post))
    {
        $pageTemplate = get_post_meta($post->ID, '_wp_page_template', true);
        if($pageTemplate == 'template-pages/page-portfolio-standar.php' )
        {
            add_meta_box(
                'page-portfolio-standar-meta-box', // $id
                esc_html__('Customize Portfolio Standar','willer'), // $title
                'willer_portfolio_standar_meta_callback', // $callback
                'page', // $page
                'normal', // $context
                'high'); // $priority
            }
        }

    }
    add_action( 'add_meta_boxes', 'willer_custom_meta_portfolio_standar' );
    ?>

The problem also occurs with WordPress 4.9.8 using Gutenberg, using the classic editor the problem is not there. I think it’s because Gutenberg uses Ajax to save the options. Do you have any suggestions to solve the problem? Thank yo

  • Gutenberg is running with React. This won't work properly anymore with PHP. – André Kelling Nov 20 '18 at 11:14
  • Yes I know that Gutenberg uses React, I was looking for a solution to improve the code of my meta-boxes. Thanks anyway for the help. – Denis Nov 20 '18 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.