0

I am working on a WordPress website in which there are a lot of wordpress plugins installed.

The plugins installed on the wordpress website has the following options:

enter image description here

When I click on View details option, I am getting the blank screen as shown below in an image but when I open in a new window or tab, it works.

On checking console, I am getting the following error (when clicking on View Details fails to open on the same page):

Blocked a frame with origin from accessing a cross-origin frame.
  at Contents
  at Function.map
  at a.fn.init.n.fn.(anonymous function) [as contents]
  and many other places. 

enter image description here

Problem Statement:

I am wondering which file I need to modify in wordpress in order to solve this error. This error seems to exist in every wordpress plugins. It works in a new tab or window but fails to work in the same page.

At this moment, I only have the wordpress admin access. I am wondering where I need to go in wordpress in order to resolve this issue. Do I need server access as well in order to make modifications in the files ?

  • Could you explain if this a local staging/test server or live production server? And which kind of server? For example OS Ubuntu Apache server etc.... – Remzi Cavdar Nov 25 '18 at 9:11
  • PS, I think something is wrong with your server and of course, you would need access to that server to solve the problem. I personally think that you would need to contact your web hosting provider if it's a live production server. – Remzi Cavdar Nov 25 '18 at 9:13
  • @RemziCavdar Its a test server but the problem exists in production server as well. Its Ubuntu. – john Nov 25 '18 at 17:39
  • @RemziCavdar I do have the access for server now. On running lsb_release -a, it has returned No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 16.04.5 LTS Release: 16.04 Codename: xenial – john Nov 25 '18 at 17:40
  • it's better to contact your hosting provider because in a default setup this would not occur. – Remzi Cavdar Nov 25 '18 at 19:18
0

This issue can be from video iframe. Which can be in widget or anywhere you used. Did you added any video iframe from any channel which has any privacy or restriction. If it's for particular plugin use case then please take a look around where you used or check plugin code or plugin issues if it has any issue then apply patch for that ?

  • He/she is clearly stating that this happens on the general plugins overview in WP admin. A widget shouldn't affect this area, it theoretically could but then it's a bad plugin/widget, to begin with. The only thing he/she could do is disable all the plugins, check if this issue still persists and activate the plugin's one by one and checking after activating a plugin. I think the server/.htaccess is not configured correctly, because this doesn't happen on a default setup/installation of WordPress. Or a combination of bad server config, bad plugin and/or theme. – Remzi Cavdar Jan 1 at 12:58
0

Your question doesn't help us much, but I will try to answer your question.

You will need the following:

  • FTP/SFTP/file access to your web server
  • Basic understanding of a default setup of WordPress

Web server

In the comments I try to troubleshoot the issue with you, you couldn't answer all my questions. I assume your web server is Apache and therefore I ask you to edit your question/post to include the .htaccess file on your server. (Just post the contents)

Example default WordPress .htaccess file

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

WordPress

I also advise disabling all your plugins and check if the issue still persists and activate plugins one by one and to check after each activation.

If you have disabled all your plugins and restored/fixed your .htaccess file, try to install and activate a different theme (preferably one of the default themes of WordPress https://wordpress.org/themes/twentyseventeen/)

Enable debugging

Enable debugging in WordPress by editing the wp-config.php file located in the root install of WordPress. Edit wp-config.php and set WP_DEBUG to true:

define( 'WP_DEBUG', true );

See for more documentation: https://codex.wordpress.org/Debugging_in_WordPress

I think the server/.htaccess is not configured correctly, because this doesn't happen on a default setup/installation of WordPress. Or a combination of bad server config, bad plugin and/or theme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.